{"id":3192,"date":"2021-09-10T15:34:20","date_gmt":"2021-09-10T15:34:20","guid":{"rendered":"https:\/\/fortgale.com\/news\/?p=3192"},"modified":"2026-06-08T22:54:17","modified_gmt":"2026-06-08T22:54:17","slug":"mshtml-vulnerability-defence-hunting","status":"publish","type":"post","link":"https:\/\/fortgale.com\/blog\/emerging-threats\/mshtml-vulnerability-defence-hunting\/","title":{"rendered":"MSHTML vulnerability \u2014 Defence and Threat Hunting"},"content":{"rendered":"\n<p style=\"text-align: justify\">The <a href=\"https:\/\/msrc.microsoft.com\/update-guide\/vulnerability\/CVE-2021-40444\">vulnerability<\/a> <strong>CVE-2021-40444<\/strong> affects the <strong>MSHTML<\/strong> engine of Internet Explorer. <br>Although the use of <strong>Internet Explorer<\/strong> has declined significantly for web browsing, many software applications use it as an internal engine, particularly all <strong>Microsoft Office<\/strong> applications (Word and PowerPoint).<\/p>\n<p style=\"text-align: justify\">This vulnerability enabled the <strong>creation of malware<\/strong> that exploits it to compromise systems <strong>through the delivery of malicious Microsoft Office documents<\/strong>.<\/p>\n<p style=\"text-align: justify\">We conducted <strong>threat hunting<\/strong> activities to identify potential attacks of this type within monitored networks.<\/p>\n\n\n\n<h1 class=\"wp-block-heading has-text-align-center\">Threat Hunting Activities<\/h1>\n\n\n\n<p style=\"text-align: justify\">Our analyst team conducted <strong>threat hunting<\/strong> activities to identify potential compromises related to the described vulnerability.<\/p>\n<p style=\"text-align: justify\">The first search consists of identifying disk writes of executable files with the <strong>.inf<\/strong> extension:<\/p>\n\n\n\n<pre class=\"wp-block-preformatted\">event_platform=win event_simpleName=PeFileWritten\n| search FileName=\"*.inf\"\n| stats dc(aid) as uniqueSystems, count(aid) as totalWrites values(FilePath) as filePaths by FileName\n| sort + totalWrites\n<\/pre>\n\n\n\n<p style=\"text-align: justify\">The second search allows identification of specific parameters in the command line launched by the rundll32 process within the &#8220;control.exe&#8221; context, to identify the initiation of early exploitation phases:<\/p>\n\n\n\n<pre class=\"wp-block-preformatted\">event_platform=win event_simpleName=ProcessRollup2 \nFileName=rundll32.exe ParentBaseFileName=control.exe\n| search CommandLine=\"*.inf*\"\n| stats dc(CommandLine) as cmdLineVarations\n dc(aid) as uniqueEndpoints count(aid) as totalExecutions \nvalues(CommandLine) as commandLines by FileName, ParentBaseFileName\n<\/pre>\n\n\n\n<h2 class=\"wp-block-heading has-text-align-center\">Attack Details<\/h2>\n\n\n\n<p style=\"text-align: justify\">The malicious file can be <strong>sent as a Microsoft Office document<\/strong> attached to an <strong>email message<\/strong>. Opening the malicious file would initiate the system compromise process.<\/p>\n<p style=\"text-align: justify\"><strong>Microsoft Office<\/strong> uses <strong>Protected View<\/strong> and <strong>Application Guard<\/strong> for Office to prevent attacks from documents received over the Internet. However, users can click the &#8220;<strong>Enable Editing<\/strong>&#8221; button, thereby disarming Microsoft&#8217;s security mechanisms.<\/p>\n<p style=\"text-align: justify\">The attack begins through the HTML file embedded in the Word document and initiates the download of the &#8220;side.html&#8221; file.<\/p>\n\n\n<div class=\"wp-block-image is-style-zoooom\">\n<figure class=\"aligncenter size-large\"><img decoding=\"async\" src=\"https:\/\/fortgale.com\/news\/wp-content\/uploads\/sites\/2\/2021\/09\/xml1.png\" alt=\"\" class=\"wp-image-3206\" loading=\"lazy\" \/><\/figure>\n<\/div>\n\n\n<p style=\"text-align: justify\">Subsequently, a <strong>.CAB<\/strong> file is downloaded and extracted as a <strong>DLL<\/strong>. Finally, the extracted file named &#8220;championship.inf&#8221; is executed. Execution of this file exploits a <strong>directory traversal attack<\/strong>, which consists of exploiting insufficient security validation of user-supplied files. Detection of such activity patterns through <a href=\"https:\/\/fortgale.com\/en\/managed-soc\/\">Managed SOC<\/a> capabilities enables rapid identification of post-exploitation indicators.<\/p>\n<p style=\"text-align: justify\">The final malware payload is a <strong>Cobalt Strike beacon<\/strong> that is launched on the victim&#8217;s machine.<\/p>\n\n\n<div class=\"wp-block-image is-style-zoooom\">\n<figure class=\"aligncenter size-large\"><img decoding=\"async\" src=\"https:\/\/fortgale.com\/news\/wp-content\/uploads\/sites\/2\/2021\/09\/code2.png\" alt=\"\" class=\"wp-image-3207\" loading=\"lazy\" \/><\/figure>\n<\/div>","protected":false},"excerpt":{"rendered":"<p>MSHTML vulnerability defensive approach: telemetry sources, hunting queries, indicators of exploitation and detection rules for SOC teams.<\/p>\n","protected":false},"author":1,"featured_media":2615,"comment_status":"closed","ping_status":"closed","sticky":false,"template":"","format":"standard","meta":{"footnotes":""},"categories":[3],"tags":[1491,1643,3237,1645,1647,3238,353,1649],"class_list":["post-3192","post","type-post","status-publish","format-standard","has-post-thumbnail","hentry","category-emerging-threats","tag-cve-it","tag-cve-2021-40444-it","tag-detection-rules","tag-exploit-it","tag-mshtml-it","tag-office-exploitation","tag-threat-hunting","tag-vulnerabiliy-it"],"_links":{"self":[{"href":"https:\/\/fortgale.com\/blog\/wp-json\/wp\/v2\/posts\/3192","targetHints":{"allow":["GET"]}}],"collection":[{"href":"https:\/\/fortgale.com\/blog\/wp-json\/wp\/v2\/posts"}],"about":[{"href":"https:\/\/fortgale.com\/blog\/wp-json\/wp\/v2\/types\/post"}],"author":[{"embeddable":true,"href":"https:\/\/fortgale.com\/blog\/wp-json\/wp\/v2\/users\/1"}],"replies":[{"embeddable":true,"href":"https:\/\/fortgale.com\/blog\/wp-json\/wp\/v2\/comments?post=3192"}],"version-history":[{"count":2,"href":"https:\/\/fortgale.com\/blog\/wp-json\/wp\/v2\/posts\/3192\/revisions"}],"predecessor-version":[{"id":9883,"href":"https:\/\/fortgale.com\/blog\/wp-json\/wp\/v2\/posts\/3192\/revisions\/9883"}],"wp:attachment":[{"href":"https:\/\/fortgale.com\/blog\/wp-json\/wp\/v2\/media?parent=3192"}],"wp:term":[{"taxonomy":"category","embeddable":true,"href":"https:\/\/fortgale.com\/blog\/wp-json\/wp\/v2\/categories?post=3192"},{"taxonomy":"post_tag","embeddable":true,"href":"https:\/\/fortgale.com\/blog\/wp-json\/wp\/v2\/tags?post=3192"}],"curies":[{"name":"wp","href":"https:\/\/api.w.org\/{rel}","templated":true}]}}